<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" lang="en" xml:lang="en">

<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <title>Considering filing for the Highline Public Schools? It’s time to get on board | The Highline Times / Des Moines News</title>
  
    
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="fb:app_id" content=""/>

<meta property="og:title" content="Considering filing for the Highline Public Schools? It’s time to get on board"/>
<meta property="og:site_name" content="The Highline Times / Des Moines News"/>

<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
<link rel="alternate" type="application/rss+xml" title="News" href="/feeds/175" />
<meta name="description" content="By Lindsay Peyton Two positions on the board of Highline Public Schools are up for election in November. Candidates may begin filing on Monday, May 15. The filing period closes at 4:30 p.m. on Friday, May 19. The deadline for candidates to withdraw is Monday, May 22 and the deadline to file as a write-in candidate is Friday, July 14." />
<meta name="abstract" content="This community's most trusted news source" />
<meta name="keywords" content="Ballard,Fremont,Robinson Newspapers" />
<meta name="copyright" content="Copyright © 2012-2013 Robinson Newspapers" />
<link rel="canonical" href="http://www.highlinetimes.com/2017/05/08/news/considering-filing-highline-public-schools-it%E2%80%99s" />
<meta name="revisit-after" content="1 day" />
  <link type="text/css" rel="stylesheet" media="all" href="http://www.highlinetimes.com/sites/robinsonpapers.com/files/css/css_aebcea630b1bed7f641747fb9606cfd0.css" />
  <link type="text/css" rel="stylesheet" media="all" href="/sites/all/themes/fusion/fusion_core/css/grid12-960.css?M"/>
  <!--[if IE 8]>
  <link type="text/css" rel="stylesheet" media="all" href="/sites/all/themes/fusion/fusion_core/css/ie8-fixes.css?M" />
  <![endif]-->
  <!--[if IE 7]>
  <link type="text/css" rel="stylesheet" media="all" href="/sites/all/themes/fusion/fusion_core/css/ie7-fixes.css?M" />
<link type="text/css" rel="stylesheet" media="all" href="/sites/all/themes/robinsonnews/css/ie7-fixes.css?M" />
  <![endif]-->
  <!--[if lte IE 6]>
  <link type="text/css" rel="stylesheet" media="all" href="/sites/all/themes/fusion/fusion_core/css/ie6-fixes.css?M"/>
<link type="text/css" rel="stylesheet" media="all" href="/sites/all/themes/robinsonnews/css/ie6-fixes.css?M"/>
  <![endif]-->
    
  <script type="text/javascript" src="http://www.highlinetimes.com/sites/robinsonpapers.com/files/js/js_7d936fb2b32da1b93660505e0b5cf346.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","lightbox2":{"rtl":0,"file_path":"\/(\\w\\w\/)sites\/robinsonpapers.com\/files","default_image":"\/modules\/freelock\/lightbox2\/images\/brokenimage.jpg","border_size":10,"font_color":"000","box_color":"fff","top_position":"","overlay_opacity":"0.6","overlay_color":"000","disable_close_click":1,"resize_sequence":0,"resize_speed":100,"fade_in_speed":100,"slide_down_speed":100,"use_alt_layout":0,"disable_resize":1,"disable_zoom":0,"force_show_nav":0,"show_caption":true,"loop_items":1,"node_link_text":"View Image Details","node_link_target":0,"image_count":"Image !current of !total","video_count":"Video !current of !total","page_count":"Page !current of !total","lite_press_x_close":"press \u003ca href=\"#\" onclick=\"hideLightbox(); return FALSE;\"\u003e\u003ckbd\u003ex\u003c\/kbd\u003e\u003c\/a\u003e to close","download_link_text":"","enable_login":true,"enable_contact":false,"keys_close":"c x 27","keys_previous":"p 37","keys_next":"n 39","keys_zoom":"z","keys_play_pause":"32","display_image_size":"original","image_node_sizes":"(\\.thumbnail)","trigger_lightbox_classes":"","trigger_lightbox_group_classes":"img.inline,img.flickr-photo-img,img.flickr-photoset-img,img.ImageFrame_image,img.ImageFrame_none,img.image-img_assist_custom,img.thumbnail, img.image-thumbnail","trigger_slideshow_classes":"","trigger_lightframe_classes":"","trigger_lightframe_group_classes":"","custom_class_handler":0,"custom_trigger_classes":"","disable_for_gallery_lists":0,"disable_for_acidfree_gallery_lists":true,"enable_acidfree_videos":true,"slideshow_interval":7000,"slideshow_automatic_start":1,"slideshow_automatic_exit":0,"show_play_pause":1,"pause_on_next_click":1,"pause_on_previous_click":1,"loop_slides":0,"iframe_width":600,"iframe_height":400,"iframe_border":1,"enable_video":0},"piwik":{"trackMailto":1},"disqus":{"url":"http:\/\/www.highlinetimes.com\/2017\/05\/08\/news\/considering-filing-highline-public-schools-it%E2%80%99s","title":"Considering filing for the Highline Public Schools? It\u2019s time to get on board","identifier":"node\/253889","shortname":"highlinetimes"},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls|xml|z|zip"},"CToolsUrlIsAjaxTrusted":{"http:\/\/www.highlinetimes.com\/2017\/05\/08\/news\/considering-filing-highline-public-schools-it%E2%80%99s":[true,true]}});
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

	    addthis_pub = 'robinsonnews';
	    addthis_logo = 'http://ballardnewstribune.com/sites/all/themes/robinson_default/images/robinsonico.jpg';
	    addthis_logo_background = 'EFEFFF';
	    addthis_logo_color = '666699';
	    addthis_brand = 'Robinson Newspapers';
	    addthis_options = 'favorites, email, digg, delicious, myspace, facebook, google, live, more';
	    addthis_disable_flash = 'false';
	
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-26788712-3", {"cookieDomain":"auto"});ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
document.write(unescape("%3Cscript src='//partner.googleadservices.com/gampad/google_service.js' type='text/javascript'%3E%3C/script%3E"));

//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
GS_googleAddAdSenseService("ca-pub-4956332358238235");
GS_googleEnableAllServices();

//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
GA_googleAddSlot("ca-pub-4956332358238235", "highline_news_region_1_slot_1");
GA_googleAddSlot("ca-pub-4956332358238235", "highline_news_region_1_slot_2");
GA_googleAddSlot("ca-pub-4956332358238235", "highline_news_region_2_slot_1");
GA_googleAddSlot("ca-pub-4956332358238235", "highline_news_region_3_slot_1");
GA_googleAddSlot("ca-pub-4956332358238235", "highline_news_region_headteasers_slot_1");

//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
GA_googleFetchAds();

//--><!]]>
</script>
  
  <script type="text/javascript" src="http://partner.googleadservices.com/gampad/google_service.js">
  </script>
  <script type="text/javascript">
    GS_googleAddAdSenseService("ca-pub-4956332358238235");
    GS_googleEnableAllServices();
  </script>
  <script type="text/javascript">
    GA_googleUseIframeRendering();
  </script>
  
    <!--[if lte IE 6]>
  <script type="text/javascript" src="/sites/all/themes/robinsonnews/js/supersleight.js"></script>
  <script type="text/javascript" src="/sites/all/themes/robinsonnews/ie6.js"></script>
  <![endif]-->
 
  <script type="text/javascript" src="/sites/all/themes/robinsonnews/js/robinsonnews.js"></script>
 
    	<link href="/feed" title="RSS 2.0" type="application/rss+xml" rel="alternate"/>
  
</head>

<body id="pid-2017-05-08-news-considering-filing-highline-public-schools-it’s" class="not-front not-logged-in page-node node-type-newsstory no-sidebars full-node layout-first-main-last sidebars-split font-size-12 grid-type-960 grid-width-12">
  <div id="page" class="page">
    <div id="page-inner" class="page-inner">
      <div id="skip">
        <a href="#main-content-area">Skip to Main Content Area</a>
      </div>

      <!-- header-top row: width = grid_width -->
      <div id="header-top-wrapper" class="header-top-wrapper full-width">
<div id="header-top" class="header-top row grid12-12">
<div id="header-top-inner" class="header-top-inner inner clearfix">
  
<div id="block-weather-3" class="block block-weather odd first  grid12-4 black-header">
  <div class="inner clearfix">
            <div class="content">
      Tuesday, May 9, 2017 | 
    Overcast, <span style="white-space:nowrap;">66.2&thinsp;°F</span>  </p>

    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
  
<div id="block-search-0" class="block block-search even   grid12-4">
  <div class="inner clearfix">
            <h2 class="title block-title">search</h2>
        <div class="content">
      <form action="http://www.highlinetimes.com/2017/05/08/news/considering-filing-highline-public-schools-it%E2%80%99s"  accept-charset="UTF-8" method="post" id="search-block-form">
<div><div id="search" class="container-inline">
  <div class="form-item">
    <input type="text" maxlength="128" name="search_theme_form" id="edit-search-theme-form-keys"  size="15" value="" title="Enter the terms you wish to search for." class="form-text" />
  </div>
  <input type="submit" name="op" id="edit-submit" value="Search"  class="form-submit" />
  <input type="hidden" name="form_token" id="edit-search-theme-form-form-token" value="334a23f79974920d21b8caf2dece3adf"  />
  <input type="hidden" name="form_id" id="edit-search-theme-form" value="search_theme_form"  />
</div>

</div></form>
    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
  
<div id="block-menu-menu-top-menu" class="block block-menu odd  last  grid12-4 black-header">
  <div class="inner clearfix">
            <div class="content">
      <ul class="menu"><li class="leaf first"><a href="/letters-to-the-editor">Letters</a></li>
<li class="leaf"><a href="/user">Sign in</a></li>
<li class="leaf"><a href="http://robinsonpapers.com/robinson-newspapers-subscription-form" title="You can use this simple information form to subscribe to ANY of the Robinson Newspapers.">Subscribe</a></li>
<li class="leaf last"><a href="/contact-us" title="Contact our Staff">Contact Us</a></li>
</ul>    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
</div><!-- /header-top-inner -->
</div><!-- /header-top -->
</div><!-- /header-top-wrapper -->

      <!-- header-group row: width = grid_width -->
      <div id="header-group-wrapper" class="header-group-wrapper full-width">
        <div id="header-group" class="header-group row grid12-12">
          <div id="header-group-inner" class="header-group-inner inner clearfix">
            
            
              
<div id="block-robinson-header_flag" class="block block-robinson odd first last  grid12-12 black-header">
  <div class="inner clearfix">
            <div class="content">
      
<a id="logo" href="/"></a>
<div class="container" id="primary-links">
  <ul id="nav" class="links">
          <li class="first"><a href="/home">Front Page</a></li>          <li class="active"><a href="/news" class="active">News</a></li>          <li class=""><a href="/sports">Sports</a></li>          <li class=""><a href="/opinion">Opinion</a></li>          <li class=""><a href="/police-blotter">Police Blotter</a></li>          <li class="last"><a href="/features">Features</a></li>      </ul>
</div>
    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
          </div><!-- /header-group-inner -->
        </div><!-- /header-group -->
      </div><!-- /header-group-wrapper -->

      <!-- preface-top row: width = grid_width -->
      <div id="preface-top-wrapper" class="preface-top-wrapper full-width">
<div id="preface-top" class="preface-top row grid12-12">
<div id="preface-top-inner" class="preface-top-inner inner clearfix">
  
<div id="block-robinson-header_teasers" class="block block-robinson odd first last  grid12-12 black-header">
  <div class="inner clearfix">
            <div class="content">
      <div id="head-teasers">
    <div class="teaser">
        <span class="chop">
                            <a href="/2017/05/06/news/aviation-day-seatac-inspires-more-1200-students">
                    <b>Aviation Day at SeaTac inspires more than 1200 students to let their dreams take flight</b>
                    The Ninth Annual Aviation Day on Saturday, May 6th, hosted by the ...                </a>
                    </span>
    </div>
    <div class="teaser">
        <span class="chop">
                            <div id="gam-holder-highline_news_region_headteasers_slot_1" class="gam-holder"><script type="text/javascript">GA_googleFillSlot("highline_news_region_headteasers_slot_1");</script></div>                    </span>
    </div>
    <div class="teaser">
        <span class="chop">
                            <a href="/2017/04/21/sports/highline-pirates-pound-river-ridge">
                    <b>Highline Pirates pound River Ridge</b>
                    By Tim Clinton
SPORTS EDITOR

Highline Pirate players took ...                </a>
                    </span>
    </div>
    <div class="teaser">
        <span class="chop">
                            <a href="/2017/03/14/opinion/pats-view-distracted">
                    <b>Pat's View:  "Distracted"</b>
                    If you are reading this while driving at a high-speed down the ...                </a>
                    </span>
    </div>
    <div class="teaser">
        <span class="chop">
                            <a href="/2017/03/14/police-blotter/police-blotter-3-20-17">
                    <b>Police Blotter: 3-20-17 </b>
                    Roommate, armed and dangerous
 A 58 year-old Burien man was ...                </a>
                    </span>
    </div>
</div>
    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
</div><!-- /preface-top-inner -->
</div><!-- /preface-top -->
</div><!-- /preface-top-wrapper -->

<div id="content-container">

      <!-- main row: width = grid_width -->
      <div id="main-wrapper" class="main-wrapper full-width">
        
        <div id="main" class="main row grid12-12">
          <div id="main-inner" class="main-inner inner clearfix">
            <div id="sidebar-first" class="sidebar-first row nested grid12-2">
<div id="sidebar-first-inner" class="sidebar-first-inner inner clearfix">
  
<div id="block-views-stories_by_section-block_1" class="block block-views odd first last  grid12-2 black-header">
  <div class="inner clearfix">
            <h2 class="title block-title">News</h2>
        <div class="content">
      <div class="view view-stories-by-section view-id-stories_by_section view-display-id-block_1 view-dom-id-1">
    
  
  
      <div class="view-content">
      <div class="item-list">
    <ul>
          <li class="views-row views-row-1 views-row-odd views-row-first">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/05/08/news/considering-filing-highline-public-schools-it%E2%80%99s" class="active">Considering filing for the Highline Public Schools? It’s time to get on board</a></span>
  </div>
</li>
          <li class="views-row views-row-2 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/05/08/news/what-makes-des-moines-great-photography-contest">What Makes Des Moines Great Photography Contest</a></span>
  </div>
</li>
          <li class="views-row views-row-3 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/05/06/news/aviation-day-seatac-inspires-more-1200-students">Aviation Day at SeaTac inspires more than 1200 students to let their dreams take flight</a></span>
  </div>
</li>
          <li class="views-row views-row-4 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/05/04/news/give-big-includes-local-non-profits-and-your-1">Give Big! includes local non-profits and your help would really make a difference; One day event is May 10</a></span>
  </div>
</li>
          <li class="views-row views-row-5 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/05/03/news/rebecca-ann-clement">Rebecca Ann Clement</a></span>
  </div>
</li>
          <li class="views-row views-row-6 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/05/02/news/sea-tac-airport-food-donation-program-enters-10th">Sea-Tac Airport food donation program enters 10th successful year</a></span>
  </div>
</li>
          <li class="views-row views-row-7 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/05/02/news/farmers-market-begins-may-4">Farmer&#039;s Market begins May 4</a></span>
  </div>
</li>
          <li class="views-row views-row-8 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/05/02/news/airport-noise-and-health-impacts-not-going-fly">Airport noise and health impacts? Not going to fly with concerned citizens</a></span>
  </div>
</li>
          <li class="views-row views-row-9 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/05/01/news/highline-students-featured-burien-art-walk">Highline Students Featured at Burien Art Walk</a></span>
  </div>
</li>
          <li class="views-row views-row-10 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/04/28/news/seatac-city-council-members-face-prickly">SeaTac City council members face off with prickly constituents</a></span>
  </div>
</li>
          <li class="views-row views-row-11 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/04/27/news/car-hits-motorcycle-sends-two-hospital">Car hits motorcycle, sends two to hospital</a></span>
  </div>
</li>
          <li class="views-row views-row-12 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/04/26/news/bite-night-brings-out-biters">Bite Night brings out the biters</a></span>
  </div>
</li>
          <li class="views-row views-row-13 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/04/24/news/sylvester-students-dig-sustainability">Sylvester Students Dig Sustainability</a></span>
  </div>
</li>
          <li class="views-row views-row-14 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/04/24/news/trimesters-credits-and-graduation-oh-my">Trimesters, credits, and graduation, oh my!</a></span>
  </div>
</li>
          <li class="views-row views-row-15 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="http://www.westseattleherald.com/2017/04/22/news/local-restaurants-participating-dining-out-life">Local restaurants participating in Dining Out for Life April 27</a></span>
  </div>
</li>
          <li class="views-row views-row-16 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/04/21/news/pcc-coming-town">PCC is coming to town</a></span>
  </div>
</li>
          <li class="views-row views-row-17 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/04/19/news/better-together">Better together</a></span>
  </div>
</li>
          <li class="views-row views-row-18 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/04/19/news/county-assessor-explains-tax-increases">County assessor explains tax increases</a></span>
  </div>
</li>
          <li class="views-row views-row-19 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/04/18/news/reduce-reuse-recycle-%E2%80%93-king-county-plans-repair">Reduce, reuse, recycle – King County plans repair event for Earth Day in White Center</a></span>
  </div>
</li>
          <li class="views-row views-row-20 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="http://www.westseattleherald.com/2017/04/18/news/art-hair-ola-salon-opening-new-location-burien">The Art of Hair: Ola Salon opening a new location in Burien</a></span>
  </div>
</li>
          <li class="views-row views-row-21 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/04/18/news/save-salmon-%E2%80%93-what-you-can-do-help">Save the salmon – what you can do to help</a></span>
  </div>
</li>
          <li class="views-row views-row-22 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/04/16/news/faa-responds-city-burien%E2%80%99s-petition-regarding">FAA Responds to City of Burien’s Petition Regarding Turbo Prop Overflights</a></span>
  </div>
</li>
          <li class="views-row views-row-23 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/04/12/news/shooting-death-near-136th-sw-may-be-gang-related">Shooting death near 136th SW may be gang related</a></span>
  </div>
</li>
          <li class="views-row views-row-24 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/04/05/news/pcc-natural-market-heading-burien-five-corners">PCC Natural Market heading to Burien at Five Corners</a></span>
  </div>
</li>
          <li class="views-row views-row-25 views-row-odd views-row-last">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2017/04/03/news/meet-candidates-next-city-manager-burien-%E2%80%93">Meet the candidates for the next city manager of Burien – community reception slated for Friday, April 7</a></span>
  </div>
</li>
      </ul>
</div>    </div>
  
  
  
  
  
      <div class="feed-icon">
      <a href="/feeds/175" class="feed-icon"><img src="/misc/feed.png" alt="Syndicate content" title="News" width="16" height="16" /></a>    </div>
  
</div>     </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
</div><!-- /sidebar-first-inner -->
</div><!-- /sidebar-first -->

            <!-- main group: width = grid_width - sidebar_first_width -->
            <div id="main-group" class="main-group row nested grid12-10">
              <div id="main-group-inner" class="main-group-inner inner">
                
                <div id="main-content" class="main-content row nested">
                  <div id="main-content-inner" class="main-content-inner inner">
                    <!-- content group: width = grid_width - (sidebar_first_width + sidebar_last_width) -->
                    <div id="content-group" class="content-group row nested grid12-6">
                      <div id="content-group-inner" class="content-group-inner inner">
                        

                        
                        <div id="content-region" class="content-region row nested">
                          <div id="content-region-inner" class="content-region-inner inner">
                            <a name="main-content-area" id="main-content-area"></a>
                                                        <div id="content-inner" class="content-inner block">
                              <div id="content-inner-inner" class="content-inner-inner inner">
                                                                                                <div id="content-content" class="content-content">
                                  
<div class="row">

  <div class="inner clearfix background black-border-top story top-story bottom-margin">
    <div class="section-strip-mini"></div>
        
    <div class="story-content">

          <h2>Considering filing for the Highline Public Schools? It’s time to get on board</h2>
    
          <h3>Two seats open</h3>
        
    <div class="meta">
            <div class='date_submitted_field'><span class="date-display-single">05/08/2017</span></div>    </div>

    
      

        
    <p><strong>By Lindsay Peyton </strong><br />
Two positions on the board of Highline Public Schools are up for election in November.<br />
Candidates may begin filing on Monday, May 15. The filing period closes at 4:30 p.m. on Friday, May 19. The deadline for candidates to withdraw is Monday, May 22 and the deadline to file as a write-in candidate is Friday, July 14.<br />
The election will be held on Tuesday, Nov. 7.<br />
The positions, each with two-year terms, will fill the seats currently held by board members Angelica Alvarez for district 2 and Joe Van for district 3.<br />
Tyrone Curry Sr, district 1, Bernie Dorsey, district 4, and Michael Spear, district 5, will retain their positions.<br />
Current board members Van and Alvarez have decided to run for reelection.<br />
 <br />
“I want to continue with what we’re working on,” Van said. “I have three kids in the system, so I have something invested. It’s not only my kids, but also their friends and my community.”</p>
<p>Alvarez, a Burien resident, had four children graduate from the district and currently has one grandchild enrolled. </p>
<p>She was originally elected in November 2009. Born and raised in San Luis, Arizona, to migrant field workers, Alvarez has a background in social services and education and believes having diverse voices on the board is important.<br />
 <div id="gam-holder-highline_story_text_region_slot_1" class="gam-holder"><script type="text/javascript">GA_googleAddSlot("ca-pub-4956332358238235", "highline_story_text_region_slot_1");</script><script type="text/javascript">GA_googleFillSlot("highline_story_text_region_slot_1");</script></div></p>
<p>Van, a resident of SeaTac, is a 1995 graduate of Tyee High School and holds an AA in Administration of Justice from Highline Community College. He is currently employed as a supervisor at Owens &amp; Minor medical supply distribution center and serves on the City of SeaTac Human Services Advisory Committee. </p>
<p>Both candidates say that state funding is a top issue for consideration. </p>
<p>“Fully funding education is one of the hottest topics,” Alvarez said. “And it especially affects our students of color. It’s one of the challenges not only for our district but one that our whole community is facing.”</p>
<p>Alvarez said another concern for the district is the lack of space in the schools for all of the families moving to the area. </p>
<p>Van said funding issues have a far-reaching ripple affect in the district. Another concern for him is the new “Core24” graduation requirements issued by the state of Washington. </p>
<p>The state mandated an increase in the minimum number of credits – from 20 to 24 – for seniors to receive their diplomas starting in 2021.  </p>
<p>“We have to look at our schedules,” he said. “Right now, if a student fails one class, he can’t graduate. We’re looking at options to help them.”</p>
<p>Van wants to continue to build the programs he believes in – like the “P-3” system which provides early education opportunities for children in pre-kindergarten through third grade. </p>
<p>He and Alvarez are also strident supporters of the dual language program, since they are both bilingual themselves. </p>
<p>“It’s important to maintain our languages, so we’re able to speak to all of our families,” Alvarez said. </p>
<p>Both candidates also believe in the need to build community partnerships. </p>
<p>“I want to bring more people in,” Van said. </p>
<p>“We can’t do it alone,” Alvarez said. “We continue to look for not just partnerships but also apprenticeships.”</p>
<p>She also wants to work more on bringing up the graduation rates. “ ‘When you go to college’ should be the expectation,” she said. “It’s not ‘if’ you’re going to go, it’s ‘when.’ I want to teach that vocabulary in the district.”</p>
<p>For more information about filing visit <a href="http://www.kingcounty.gov/depts/elections" title="www.kingcounty.gov/depts/elections">www.kingcounty.gov/depts/elections</a>.<br />
 <div id="gam-holder-highline_story_text_region_slot_2" class="gam-holder"><script type="text/javascript">GA_googleAddSlot("ca-pub-4956332358238235", "highline_story_text_region_slot_2");</script><script type="text/javascript">GA_googleFillSlot("highline_story_text_region_slot_2");</script></div></p>
    <ul class="links inline"><li class="addthis first"><span>
      <a class="addthis-button" href="http://www.addthis.com/bookmark.php"
        onfocus="return addthis_open(this, '', '[URL]', '[TITLE]')"
        onmouseover="return addthis_open(this, '', '[URL]', '[TITLE]')"
        onblur="addthis_close()"
        onmouseout="addthis_close()"
        onclick="return addthis_sendto()"><img src="http://s9.addthis.com/button1-share.gif" width="125" height="16" alt="share" class="addthisimage" /></a><script type="text/javascript" src="http://s7.addthis.com/js/152/addthis_widget.js"></script></span></li>
<li class="fb_social_like"><span><div class="fb-social-like-widget"><fb:like  href="http://www.highlinetimes.com/2017/05/08/news/considering-filing-highline-public-schools-it%E2%80%99s" send="false" layout="button_count" show_faces="false" width="100" action="like" font="verdana" colorscheme="light"></fb:like></div></span></li>
<li class="tweet_Twitter last"><a href="http://twitter.com/?status=www.tinyurl.com/mm873zf%20Considering%20filing%20for%20the%20Highline%20Public%20Schools%3F%20It%E2%80%99s%20time%20to%20get%20on%20board" class="tweet" rel="nofollow" target="_blank"><img src="/sites/all/modules/tweet/twitter.png" alt="Post to Twitter" title="Post to Twitter" width="16" height="16" /></a></li>
</ul>    <div class="gallery"><h3 class="gallery-title">Photo gallery for this story</h3><a rel="lightbox[images]" title="Angelica Alvarez" href="http://www.highlinetimes.com/sites/robinsonpapers.com/files/imagecache/popup_image/images/wwwhighlinetimescom/2017/05/500-2-angelicaalvarez.jpg" ><img src="http://www.highlinetimes.com/sites/robinsonpapers.com/files/imagecache/article_gallery_thumb/images/wwwhighlinetimescom/2017/05/500-2-angelicaalvarez.jpg" alt="" title="Angelica Alvarez" /></a><a rel="lightbox[images]" title="Joe Van" href="http://www.highlinetimes.com/sites/robinsonpapers.com/files/imagecache/popup_image/images/wwwhighlinetimescom/2017/05/500-1-joevan2.jpg" ><img src="http://www.highlinetimes.com/sites/robinsonpapers.com/files/imagecache/article_gallery_thumb/images/wwwhighlinetimescom/2017/05/500-1-joevan2.jpg" alt="" title="Joe Van" /></a></div>    </div><!-- /content -->
  </div>
</div><!-- /row -->

<p id="comments-prepend">We encourage our readers to comment. No registration is required. We ask that you keep your comments free of profanity and keep them civil. They are moderated and objectionable comments will be removed.</p>
<div id="disqus_thread"></div><noscript><div class="disqus-noscript"><a href="http://highlinetimes.disqus.com/?url=http%3A%2F%2Fwww.highlinetimes.com%2F2017%2F05%2F08%2Fnews%2Fconsidering-filing-highline-public-schools-it%25E2%2580%2599s">View the discussion thread.</a></div></noscript>

                                                                  </div><!-- /content-content -->
                                                              </div><!-- /content-inner-inner -->
                            </div><!-- /content-inner -->
                          </div><!-- /content-region-inner -->
                        </div><!-- /content-region -->

                                              </div><!-- /content-group-inner -->
                    </div><!-- /content-group -->

                    <div id="sidebar-last" class="sidebar-last row nested grid12-4">
<div id="sidebar-last-inner" class="sidebar-last-inner inner clearfix">
  
<div id="block-google_admanager-112b30eb96b14bd99046dc4c7ded012c" class="block block-google_admanager odd first  grid12-4 black-header">
  <div class="inner clearfix">
            <div class="content">
      <div id="gam-holder-highline_news_region_1_slot_1" class="gam-holder"><script type="text/javascript">GA_googleFillSlot("highline_news_region_1_slot_1");</script></div>    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
  
<div id="block-google_admanager-b433dcd3b70c0b8def84cb8ca10cea2d" class="block block-google_admanager even   grid12-4 black-header">
  <div class="inner clearfix">
            <div class="content">
      <div id="gam-holder-highline_news_region_1_slot_2" class="gam-holder"><script type="text/javascript">GA_googleFillSlot("highline_news_region_1_slot_2");</script></div>    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
  
<div id="block-google_admanager-028ab4d2898fe772cc29f90dbcd8fdc7" class="block block-google_admanager odd   grid12-4 black-header">
  <div class="inner clearfix">
            <div class="content">
      <div id="gam-holder-highline_news_region_2_slot_1" class="gam-holder"><script type="text/javascript">GA_googleFillSlot("highline_news_region_2_slot_1");</script></div>    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
  
<div id="block-block-13" class="block block-block even   grid12-4 black-header">
  <div class="inner clearfix">
            <div class="content">
      <p><a href="http://twitter.com/hltimes"><img src="/sites/robinsonpapers.com/files/followusontwitter.png" /></a><br />
Receive updates on news and events in the Highline area via Twitter or Facebook!<br />
<br />
<a href="http://www.facebook.com/people/Highline-Times/100000721443724" title="Highline Times" target="_TOP"><br />
<img src="http://badge.facebook.com/badge/100000721443724.48.629088368.png" width="120" height="249" /><br />
</a></p>
    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
  
<div id="block-fb_social_likebox-likebox" class="block block-fb_social_likebox odd   grid12-4 black-header">
  <div class="inner clearfix">
            <h2 class="title block-title">Facebook</h2>
        <div class="content">
      <fb:like-box  href="" width="292" height="285" colorscheme="light" connections="10" stream="false" header="true"></fb:like-box>    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
  
<div id="block-google_admanager-492a440897f5a21ed121519201b967ef" class="block block-google_admanager even  last  grid12-4 black-header">
  <div class="inner clearfix">
            <div class="content">
      <div id="gam-holder-highline_news_region_3_slot_1" class="gam-holder"><script type="text/javascript">GA_googleFillSlot("highline_news_region_3_slot_1");</script></div>    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
</div><!-- /sidebar-last-inner -->
</div><!-- /sidebar-last -->
                  </div><!-- /main-content-inner -->
                </div><!-- /main-content -->

                
              </div><!-- /main-group-inner -->
            </div><!-- /main-group -->
          </div><!-- /main-inner -->
        </div><!-- /main -->
        
      </div><!-- /main-wrapper -->

                    
      <!-- postscript-bottom row: width = grid_width -->
                    
</div><!-- /content-container -->

      <!-- footer row: width = grid_width -->
      
      <!-- footer-message row: width = grid_width -->
      <div id="footer-message-wrapper" class="footer-message-wrapper full-width">
        <div id="footer-message" class="footer-message row grid12-12">
          <div id="footer-message-inner" class="footer-message-inner inner clearfix">
                        
            <b>Web development by <a href="http://freelock.com" target="_blank">Freelock Computing</a></b>
            &copy; 2017 Robinson Communications Inc. All Rights Reserved.
            <a href="/contact-us">Contact Us</a>
              <a href="/terms_of_service">Terms</a>
              
                                    <a href="/robinson-newspapers-subscription-form">Home Delivery</a>
                                    <a href="/feed" rel="alternate" type="application/rss+xml">
            <img src="http://www.feedburner.com/fb/images/pub/feed-icon16x16.png" alt="" style="vertical-align:middle;border:0" />
            </a><br>
            Media kit available on request -- contact Donao@robinsonnews.com
          </div><!-- /footer-message-inner -->
        </div><!-- /footer-message -->
        <br class="clear" />
      </div><!-- /footer-message-wrapper -->

    </div><!-- /page-inner -->
  </div><!-- /page -->
  <div id="fb-root"></div><script type="text/javascript">
     window.fbAsyncInit = function() {
       FB.init({
         appId: "",
         status: true, 
         cookie: true,
         xfbml: true,
         channelUrl: "http:\/\/www.highlinetimes.com\/fb_social\/channel"
       });
       
       FB.Event.subscribe("edge.create", function(href, widget) {
_gaq.push(["_trackEvent", "Facebook like", "Drupal", href]);
});
       
         
     };
     (function() {
       var e = document.createElement('script'); 
       e.async = true;
       e.src = document.location.protocol + '//connect.facebook.net/en_US/all.js';
       document.getElementById('fb-root').appendChild(e);
     }());
  </script><script type="text/javascript">
<!--//--><![CDATA[//><!--
var _paq = _paq || [];(function(){var u=(("https:" == document.location.protocol) ? "https://pilchuk.freelock.com/" : "http://piwik.freelock.com/");_paq.push(["setSiteId", "25"]);_paq.push(["setTrackerUrl", u+"piwik.php"]);_paq.push(["setDownloadExtensions", "7z|aac|arc|arj|asf|asx|avi|bin|csv|doc|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls|xml|z|zip"]);_paq.push(["setDoNotTrack", 1]);_paq.push(["trackPageView"]);_paq.push(["setIgnoreClasses", ["no-tracking","colorbox"]]);_paq.push(["enableLinkTracking"]);var d=document,g=d.createElement("script"),s=d.getElementsByTagName("script")[0];g.type="text/javascript";g.defer=true;g.async=true;g.src=u+"piwik.js";s.parentNode.insertBefore(g,s);})();
//--><!]]>
</script>
  
  <!-- Start Quantcast tag -->
  <script type="text/javascript">
    _qoptions={
      qacct:"p-04cWTlFWpKYdM" 
    };
  </script>
  <script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
  <noscript>
    <img src="http://pixel.quantserve.com/pixel/p-04cWTlFWpKYdM.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
  </noscript>
  <!-- End Quantcast tag -->
</body>
</html>

